Вопрос: Opera требует, чтобы я обновлялся, чтобы использовать VPN, но Opera уже в новейшей версии


Прямо сейчас в Opera с моим Ubuntu 14.04 говорится, что это версия 45.0.2552.898.

Затем говорится:

Требуется обновление браузера

VPN не поддерживается в вашей текущей версии Opera. Обновите   в новостной версии Opera, чтобы продолжить использование службы VPN.

Однако в разделе «О Opera» также говорится

45.0.2552.898 - Opera обновлена

Я попытался удалить и установить с помощью apt-get снова, но

Настройка opera-stable (45.0.2552.898)

Я также попытался загрузить файлы DEB и RPM с opera.com, но они также являются той же самой версией.

Любые идеи, что происходит или как их решить?


4
2018-01-04 21:36


Источник


Возможно, ошибка / проблема с Opera или сама служба VPN - кажется, у вас есть последняя версия, так как ваша версия также доступна через веб-сайт Opera. - JonasCz
+1 Аналогичная проблема на моей стороне. Следует отметить, что вы используете 32-битную систему или 64-битную систему. Похоже, 32-битная поддержка была окончена. Я могу отправить альтернативный ответ в ближайшее время. - clearkimura


Ответы:


Если вы используете версию 32-разрядной версии 14.04, страница «О Opera» действительно будет выглядеть так:

Версия: 45.0.2552.898 - Opera обновлена

Обновить поток: Стабильный

Система: Ubuntu 14.04.5 LTS (x86; XFCE)

Последнее обсуждение, проведенное в ноябре 2017 года, было найдено как эта тема на форумах Opera, который дает прямой ответ от модератора.

Нет, поддержка 32-разрядных версий Linux закончилась.

Для официальной информации, этот датированный пост «Часто задаваемые вопросы об Opera для Linux» в конце декабря 2014 года в блогах Opera, в которых упоминалось только 64-разрядная Opera, предоставляется для последних выпусков.

Доступна ли Opera для 32-разрядной Linux?

Последняя стабильная версия Opera для Linux - это только 64-разрядная версия, основанная на том, что установили большинство пользователей Linux. Однако мы имеем версии разработчика 32-разрядной версии Opera^ 1.

^ 1 Эта ссылка указывает на другую устаревшую публикацию с Opera Developer 30 в 2015 году. Ссылка цитируется в любом случае, поскольку в сообщении упоминается снижение использования 32-разрядных Linux-систем.

В последнее время добавляется ограничение «Обновление браузера». Я все еще мог использовать VPN-сервис от Opera для Linux до конца 2017 года.

В любом случае, последние версии Opera для Linux предназначены только для 64-битных систем.


1
2018-01-05 10:37





Похоже, что довольно легко добраться до последней стабильной версии Opera под Ubuntu 14.04, а версия 50.0.2762.45, безусловно, имеет действующую VPN в моей системе. Добавьте следующий PPA и установите opera-stable:

sudo sh -c 'echo "deb http://deb.opera.com/opera-stable/ stable non-free" >> /etc/apt/sources.list.d/opera.list' 
wget -O - http://deb.opera.com/archive.key | sudo apt-key add -
sudo apt-get update
sudo apt-get install opera-stable

Это отлично работало на моей системе Ubuntu 14.04, как показано на следующем скриншоте:

enter image description here

И еще один скриншот, показывающий VPN на работе:

enter image description here

Рекомендации:


2
2018-01-04 22:59



Правильно с помощью этого метода вы можете получить версию Opera Stable 50.0.2762.45, и VPN работает отлично, я просто попробовал это сам. +1 =) - galoget
@galoget Новая Opera выглядит очень, очень приятно ... - andrew.46
Спасибо, я не могу проверить прямо сейчас, но я вернусь к вам позже. - Michael
Я попробовал это, и он все еще выдавал мне блокирующее сообщение при включении VPN. Я думаю, ваше решение будет работать на 64-битной основе. Я все еще на 32-битной - Michael
Поддержка @Michael 32bit медленно исчезает во многих областях ... - andrew.46