Вопрос: Установка / обновление до Apache ant 1.8.2


Как установить / обновить Apache Ant 1.8.2 с помощью apt-get на Ubuntu natty. Я пытался sudo apt-get upgrade ant а также sudo apt-get install ant(после удаления уже установленной версии, т.е. 1.8.1), но ничего не работает. Каждый раз, когда он устанавливает только Ant 1.8.1.


4
2017-08-02 11:57


Источник




Ответы:


Как вы нашли - вы не можете «обновить» этот путь. Хранилища обычно представляют собой стабильные базы кода, обновляемые только с исправлениями стабильности и безопасности - редко более новыми версиями приложений.

Команда eclipse упаковала v1.8.2 муравья через их PPA,

Если вы хотите спуститься по этому маршруту

sudo add-apt-repository ppa:eclipse-team/debian-package
sudo apt-get update

3
2017-08-02 12:34



Следует отметить, что PPA не являются «официальными» и могут привести к повреждению системы. Пожалуйста, используйте их экономно и только тогда, когда вы доверяете автору. - Marco Ceppi♦
Согласился с Марко. Вы должны использовать только PPA, если вы абсолютно доверяйте источнику (источникам) - Thomas Ward♦
В дополнение к этому, если ваша версия ubuntu не имеет add-apt-repository вы можете установить его с помощью sudo apt-get install python-software-properties - Conrad.Dean


1.8.2 еще не упакован для Natty, самая последняя упакованная версия Ant в архивах Natty - это 1.8.1-1, 1.8.2 был упакован для Oneiric, поэтому вы можете либо дождаться выхода Oneiric, либо вы можете следовать Обратный запрос и попросите, чтобы пакеты Oneiric были отправлены обратно в Natty.

Вы также можете скомпилировать Ant из источника, если хотите, но это может вызвать проблемы, если вы когда-нибудь захотите вернуться к запуску Ant через репозитории.


1
2017-08-02 12:30