Вопрос: Загрузка и установка последней версии KILE


в TeX - LaTeX группе Stack Exchange, я задал вопрос о версии TeXLive под Ubuntu, Поскольку я установил последнюю версию TeXLive под Ubuntu, я хочу иметь возможность использовать ее при запуске интегрированной среды разработки, такой как KILE. Хотя решение (и исправление) было представлено на Группа поддержки поддержки KILE, это включает в себя загрузку, компиляцию и установку последней версии KILE.

Чтобы скомпилировать KILE, мне нужно:

  1. Библиотеки KDE 4.2 или лучше
  2. Qt 4.5 или лучше
  3. Cmake 2.6.2 или лучше
  4. Недавняя компиляция на C ++, например GCC 4.4

Моя проблема в том, что я не могу определить, какая версия библиотек KDE или Qt, которые я установил в своей системе. Обратите внимание, что я запускаю Ubuntu версии 11.04.

Мой вопрос, однако, в том, будет ли последняя версия KILE (версия 2.1) включена в следующую версию Ubuntu (т. Е. Версия 11.10). Если это так, я мог бы сэкономить усилия и горе для компиляции и установки KILE. В противном случае моя установка последней версии повлияет на способность диспетчера пакетов Synaptic применять любые будущие версии / обновления для KILE?

Любая помощь / предложения будут оценены.


4
2017-09-08 23:42


Источник




Ответы:


Согласно исходная страница для kile, 11.04 поставляется с 1:2.1.0~svn1112278beta4-2ubuntu2, а также 1:2.1.0~svn2010122beta5-1ubuntu1~natty1 доступен как резервный.

11.10 уже имеет 2.1.0 финала.

У этого человека, похоже, есть PPA от Kile 2.1, так что вам не нужно его компилировать самостоятельно:

https://launchpad.net/~kile/+archive/stable

Вы можете найти информацию о том, как добавлять и использовать PPA здесь:

Вот фрагмент командной строки о том, как ее использовать:

sudo add-apt-repository ppa:kile/stable
sudo apt-get update
sudo apt-get upgrade

Обновит ваш киле до этой версии (2.1). Ubuntu автоматически отключает PPA при следующем обновлении ОС, и обычно вы просто забираете самую новую версию, доступную в то время.


4
2017-09-09 00:09



Это сработало! Еще раз спасибо за вашу помощь! Разумеется, я отправлю это решение обратно в группу TeX - LaTeX под Stack Exchange. BTW. Исправьте меня, если я ошибаюсь, но будет ли PPA похожим на порты Дарвина? - Bill
Ага! Я понял, как много! Благодаря! - Bill
Кажется, что ppa не подходит для прецизионного панголина. Не так ли? - Alessandro Cuttin
Нет, 2.1.0 уже в 12.04. - Jorge Castro
@JorgeCastro На самом деле, это так, но я испытываю непрерывные сбои приложения. Я задавался вопросом, есть ли способ перейти на Kile 2.1.2 - Alessandro Cuttin