Вопрос: dpkg-deb: ошибка: паст подпроцесса был убит сигналом (Broken pipe)


Программное обеспечение до даты Опция автоматически загружает обновление для GIMP. но при установке его давая мне ошибку. как обновить


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  gimp
Suggested packages:
  gimp-help-en gimp-help libgimp-perl gimp-gap gimp-console
The following packages will be upgraded:
  gimp
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/4,388 kB of archives.
After this operation, 324 kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 151157 files and directories currently installed.)
Preparing to replace gimp 2.6.11-2ubuntu4 (using .../gimp_2.7.4-2011102201~oo_amd64.deb) ...
Unpacking replacement gimp ...
dpkg: error processing /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


4
2017-11-16 18:30


Источник




Ответы:


Если вы используете настраиваемый PPA для Gimp, удалите его.

Удалить пакет gimp-plugin-registry а также gimp

sudo apt-get remove gimp-plugin-registry gimp

Исправить пакеты

sudo apt-get -f

Обновление пакета Gimp

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install gimp gimp-plugin-registry

устанавливать gimp-plugin-registry а также gimp

sudo apt-get install gimp-plugin-registry gimp

2
2017-11-16 19:09



--------------------------------- Я попытался удалить пакет, но, похоже, все взаимозависимо. Я следую Ошибка Чтение списков пакетов ... Готово Создание дерева зависимостей Чтение информации о состоянии ... Готово Вы можете запустить «apt-get -f install», чтобы исправить следующее: Следующие пакеты имеют неудовлетворенные зависимости: gimp: Depends: libgimp2.0 ( <= 2.6.11-z), но должен быть установлен 2.7.4-2011102201 ~ oo Зависимости: данные gimp (<= 2,6.11-z), но 2.7.4-2011102201 ~ oo должны быть установлены E: Неудовлетворенные зависимости , Попробуйте «apt-get -f install» без пакетов (или укажите решение). - Manish Varia
при запуске apt-get -f install я снова получаю ту же ошибку. - Manish Varia
На данный момент активен какой-либо gimp PPA? - Bruno Pereira
Нет. Я только что установил его позавчера .. !! сегодня перезапустил мою машину, а затем обновил программное обеспечение, сообщив, что доступны обновления, установите те, которые я только что установил. - Manish Varia
попробуйте удалить оба пакета, обновить и исправить их, а затем попытаться установить. - Bruno Pereira


gimp содержит файл /usr/lib/gimp/2.0/plug-ins/file-xmc который уже установлен пакетом gimp-plugin-registry, Как файл может быть только из одного пакета, вы не можете установить оба пакета.

Судя по номеру версии, ваш пакет gimp (но не gimp-plugin-registry) не является неофициальным источником пакета. Поэтому вам следует попробовать найти пакет gimp-plugin-registry который работает с этим пакетом gimp или возвращается к официальному пакету gimp.


1
2017-11-16 19:06



Я попытался удалить пакет, но, похоже, все взаимозависимо. Я получаю следующее сообщение об ошибке. Создание дерева зависимостей. Чтение информации о состоянии ... Готово. Возможно, вы захотите запустить «apt-get -f install», чтобы исправить это: следующие пакеты неудовлетворены зависимостей: gimp: Зависит: libgimp2.0 (<= 2,6.11-z), но 2.7.4-2011102201 ~ oo должен быть установлен Зависит: данные gimp (<= 2,6.11-z), но 2.7.4-2011102201 ~ oo должна быть установлена ​​E: Неудовлетворенные зависимости. Попробуйте «apt-get -f install» без пакетов (или укажите решение). при запуске apt-get -f install -> Back to square 1, такая же ошибка - Manish Varia


dpkg: error processing /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb (--unpack):
trying to затирать '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Хорошо, это общий ответ скорее о проблеме OP.

Это сообщение указывает, что какой-то пакет пытается переписать файл, который включен в другой. Самым безопасным решением является удаление одного из двух пакетов. В этом примере это может быть gimp или gimp-plugin-registry,

Обычно это связано с добавлением не очень хорошо поддерживаемых PPA, поскольку эти проблемы фиксируются ботами в основных хранилищах.


1
2017-12-18 13:12