Вопрос: программный центр обновления-менеджер как получить segmentation fault


Я использую Ubuntu 11.10. После обновления ни программный центр, ни менеджер обновлений не будут работать. Я получаю ошибка сегментации при запуске с консоли. я могу сделать sudo apt-get update без проблем, но обновление не работает и установка любого пакета, то есть,sudo apt-get upgrade или sudo apt-get install emacs просто возвращает запрос назад, и ничего не происходит.

Точнее: software-center дает следующее: 2012-01-30 16:07:17,144 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21 Segmentation fault Тогда ничего другого не происходит. С update-manager: Segmentation fault Окно вспыхивает и немедленно уходит. С sudo apt-get install emacs а также sudo apt-get upgrade ничего не происходит с любой из этих двух команд. sudo apt-get upgrade работает хорошо, хотя


4
2018-01-30 13:29


Источник


Не могли бы вы добавить точное сообщение об ошибке на свой вопрос? - Nitin Venkatesh
Точнее: $ software-center дает следующее: 2012-01-30 16:07:17,144 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21 Segmentation fault Тогда ничего другого не происходит. С $ update-manager Segmentation fault Окно вспыхивает и немедленно уходит. С $ sudo apt-get install emacs а также $ sudo apt-get upgrade ничего не происходит ни с одной из этих двух последних команд. ( $sudo apt-get upgrade хорошо работает) François - François


Ответы:


В соответствии с эту тему на форумах Ubuntu  (для которого решение было первоначально найдено на эта тема):

Вопрос:

Когда я нажимаю «Система»> «Администрирование»> «Диспетчер обновлений», он появляется (отображается серым цветом), и появляется небольшое окно «Запуск диспетчера обновлений», но когда панель заполняется наполовину, она исчезает.

Ответ:

Согласно теме форума из архива, http://ubuntuforums.org/showthread.php?t=19563, вы должны решить эту проблему, выполнив следующую команду с терминала:

sudo rm /var/cache/apt/*.bin

4
2018-01-30 18:42



Это сработало отлично. Спасибо. - François
Наиболее желанный :) - Nitin Venkatesh
Просто была та же проблема, но / var / cache / apt не имеет * .bin-файлов в нем. Любые другие предложения? - Peter Flynn