Вопрос: Блокировки клавиатуры в IntelliJ IDEA на Ubuntu 14.04


Не могли бы вы помочь мне с черной странной проблемой? Я использую Intellij IDEA 13 на Ubuntu 14.04, и время от времени моя клавиатура полностью (да, полностью, это не о ярлыках) блокирует в IDEA. Я все еще могу делать все, что хочу в IDEA с помощью мыши, также я могу использовать клавиатуру везде, кроме IDEA. И это можно исправить только перезапуском IDEA.

Может ли кто-нибудь дать подсказку, пожалуйста?


164
2017-07-24 06:58


Источник


Может быть, ваша клавиатура просто захватывается некоторым полем внутри IntelliJ? Это случайная вещь или что-то конкретное срабатывает? - Ruraj
Я не думаю, что какое-то поле может захватить такую ​​клавиатуру, но я буду проверять ее более точно в следующий раз. И это кажется случайным. - Treble Snake
Мой коллеж и я испытываем то же самое (то же ОС и IntelliJ 13.1.4). Я должен перезапустить IntelliJ один раз каждые несколько часов (я могу использовать Alt-F4, хотя) - очень раздражает. Я также считаю, что это происходит совершенно случайно. В прошлый раз я был в середине редактирования HTML-файла. Не нажимайте ярлык. - Halle Knast
У меня было два экземпляра IntelliJ, и они оба застыли. Не знаю, насколько это актуально, но когда я закрываю IDE, отключение запущенного сервера приложений обычно занимает очень короткое время. После того, как произойдет замораживание, я должен отменить это, потому что он, похоже, не заканчивается. - Halle Knast
Это проблема Java, которая влияет на другие графические интерфейсы Java Swing, включая интерфейс SOAP. «ibus-daemon -rd» также исправляет проблему - rjdkolb


Ответы:


Eсть открытый вопрос в jetbrains youtrack для идеи intellij которые рекомендуют два решения:

  1. Ввод клавиатуры можно разблокировать, перезапустив демон IBus с консоли:

    ibus-daemon -rd
    
  2. IBus можно отключить для IDEA, отключив env. переменные XMODIFIERS, но возможность ввода национальных символов в IDEA будет потеряна:

    XMODIFIERS="" idea.sh
    

Я использовал второй и исправил свою проблему.


206
2017-10-18 16:50



> «ibus-daemon -rd» с консоли. Это сработало! Большое спасибо!) - Treble Snake
6 месяцев спустя вариант 1 больше не рекомендуется, так как это может привести к сбою JVM: / - mike
Что вы имеете в виду национальные персонажи, @Mike, это сработало для меня сегодня 2 июня - Abderrahmane TAHRI JOUTI
«ibus-daemon -rd» - я всерьез подумываю, чтобы татуировать это на моей руке. - Balázs Mária Németh
Последнее обновление по этому вопросу (17 июня 2015 года) рекомендует export IBUS_ENABLE_SYNC_MODE=1 - Nacho Coloma


Я смог решить это с помощью того, что нашел Вот что в основном добавляет export XMODIFIERS="" на idea.sh


14
2018-03-05 16:45



похоже, работает здесь! - Marc Hauptmann


Для постоянное решение,  Обновление 01 октября 2015 года по этому вопросу рекомендует:

Либо обновите IBus до версии 1.5.11, либо добавьте export IBUS_ENABLE_SYNC_MODE=1 на ваш ~/.profile, затем перезапустите сеанс.

Кроме того, вы можете отключить IBus System Settings | Language Support | Keyboard input method,

IDEA 15 покажет предупреждение, если используется несовместимая версия IBus.


5
2017-11-30 11:53





Я пробовал это и работаю до сих пор, но я обновлю, если он снова замерзнет. Я видел предложение на youtrack, которое предлагает отключить iBus, который, кажется, вмешивается, особенно из-за использования ярлыка ctrl + space для изменения настроек языка. Вы можете сделать это, перейдя к:

язык поддержка> клавиатура вход метод система> нет

enter image description here

**** ОБНОВИТЬ *****

После некоторого времени работы этот метод все еще не работал, поскольку я продолжал замерзать. Наверное, теперь я буду придерживаться следующего обходного пути, чтобы перезапустить ibus, что немного неудобно, но что вы можете сделать.

идти в терминал

тип:

ibus-daemon -rd

1
2018-04-05 00:33



благодаря, ibus-daemon -rd это то, что я искал. - Lambart