Вопрос: Проблема установки Tellico с Ubuntu 14.10


Я обновил свою систему до последней версии ubuntu с 14.04 по 14.10. Похоже, что он удалил мой tellico, который был установлен и удалил зависимости :-( Grrrr!

Я попробовал apt-get установить Tellico и получил следующие недостающие зависимости. Может ли кто-нибудь помочь мне в разрешении этого?

Я думаю, что обновление удалило общие зависимости / библиотеки KDE?

Someone@MSTUltra:~$ sudo apt-get install tellico
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
tellico : Depends: tellico-data (= 2.3.8+dfsg.2-1ubuntu1) but 2.3.9-0ubuntu0~ppa2 is to be installed
E: Unable to correct problems, you have held broken packages.

Такая же проблема возникает при установке через программный центр, см. Ниже

The following packages have unmet dependencies:
 tellico: Depends: tellico-data (= 2.3.8+dfsg.2-1ubuntu1) but 2.3.9-0ubuntu0~ppa2 is to be installed
 Depends: libc6 (>= 2.4) but 2.19-10ubuntu2 is to be installed
 Depends: libgcc1 (>= 1:4.1.1) but 1:4.9.1-16ubuntu6 is to be installed
 Depends: libkabc4 (>= 4:4.7) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libkcal4 (>= 4:4.7) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libkcddb4 (>= 4:4.3.4) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libkdecore5 (>= 4:4.7) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libkdeui5 (>= 4:4.7.0) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libkhtml5 (>= 4:4.7) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libkio5 (>= 4:4.7.0) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libknewstuff3-4 (>= 4:4.7) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libkparts4 (>= 4:4.7) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libkresources4 (>= 4:4.7) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libksane0 (>= 4:4.3.4) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libkxmlrpcclient4 (>= 4:4.7) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libqimageblitz4 (>= 1:0.0.4) but 1:0.0.6-4build1 is to be installed
 Depends: libqt4-dbus (>= 4:4.5.3) but 4:4.8.6+git49-gbc62005+dfsg-1ubuntu1 is to be installed
 Depends: libqt4-network (>= 4:4.5.3) but 4:4.8.6+git49-gbc62005+dfsg-1ubuntu1 is to be installed
 Depends: libqt4-xml (>= 4:4.5.3) but 4:4.8.6+git49-gbc62005+dfsg-1ubuntu1 is to be installed
 Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.6+git49-gbc62005+dfsg-1ubuntu1 is to be installed
 Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.6+git49-gbc62005+dfsg-1ubuntu1 is to be installed
 Depends: libsolid4 (>= 4:4.7) but 4:4.14.1-0ubuntu1 is to be installed
 Depends: libstdc++6 (>= 4.9) but 4.9.1-16ubuntu6 is to be installed
 Depends: libxml2 (>= 2.7.4) but 2.9.1+dfsg1-4ubuntu1 is to be installed
 Depends: libyaz4 (>= 4.0.1) but 4.2.30-4 is to be installed

Благодаря :-)


0
2017-11-30 15:45


Источник




Ответы:


Чтобы устранить неудовлетворенные зависимости, выполните следующую команду с вашего терминала

sudo apt-get -f install

Если проблема все еще сохраняется, рассмотрите упомянутое решение Вот


0
2017-11-30 15:50