Вопрос: Раздражающее мерцание в 16.04 LTS - Chrome


Я обновил с 4.4.0 до 4.4.8, а затем 4.5.2 на Ubuntu 16.04 LTS 64-bit, и это все еще происходит.

На 4.5.2 он еще чаще, и в основном в Chrome (еще не пробовал firefox или opera). Каждый раз, когда я открываю новую веб-страницу. Любой способ исправить это, или это ошибка?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Приветствия.


193
2018-05-03 06:31


Источник


То же самое происходит с Ubuntu 14.04.4 - Billal BEGUERADJ
Я также сталкиваюсь с той же проблемой, особенно при использовании facebook. Это слишком раздражает. - sgiri
Пытаться --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers   Дополнительная информация здесь: productforums.google.com/forum/#!topic/chrome/... - Postadelmaga
Гуглер здесь. Эта ошибка отслеживается в трекере Chromium # 606152 - Мерцание на Intel с однократными загрузками, - Dan Dascalescu
Я переключился на стек HWE (ядро 4.8 и X-7.7). Он остановил мерцание. Существует некоторая проблема с i915 (Графический драйвер Intel HD) в серии 4,4. - Manoj Sawai


Ответы:


После некоторых исследований я нашел решение этой проблемы. Сейчас он работает для меня.

Я отключил аппаратное ускорение для своего браузера от

Settings > Advance Settings > System > uncheck the hardware acceleration

Надеюсь, это сработает на вашей машине.


я использую google-chrome-stable Version 50.0.2661.94 (64-bit) на Ubuntu 16.04

-----РЕДАКТИРОВАТЬ----

Если вы сталкиваетесь с задержкой прокрутки и разрывом экрана. Сделайте так, как это было предложено Амос Фоларин в комментарии ниже:

Идти к: chrome://flags/#smooth-scrolling и включить его.


184
2018-05-05 17:54



Я пробовал это, исправляет проблему, но делает свое прокручивающееся отставание и разрывы экрана. - Mookey
Это действительно не должно быть принято, так как это не решение, это определенно работа. - theV0ID
Это не влияет на мерцание для меня. - DavidJ
Это решение работало для моего XPS13 9343, мерцание определенно остановилось или не заметно. Я также попробовал другое решение, предлагаемое здесь, чтобы установить chrome: // flags / # enable-gpu-rasterization в «Force-enabled для всех слоев», но это не сработало, казалось, что отключено аппаратное ускорение в хроме. Но согласитесь с @ theV0ID, что его идея не идея. - Amos Folarin
Попробуйте также включить chrome: // flags / # smooth-scrolling для плавной прокрутки. Я использую XPS13 + Ubuntu16.04, хорошо работает с опцией аппаратного ускорения без проверки - Amos Folarin


У меня была такая же проблема, что установка растровой графики на GPU для принудительного включения всех слоев, по-видимому, наконец-то работает:

Chrome Flags: GPU rasterization


158
2017-08-08 07:52



быстрая ссылка: chrome: // flags / # enable-gpu-rasterization - JohannesNE
работал на меня тоже. - Sufiyan Ghori
Он перестал работать, мерцание вернулось, думаю, после обновления до версии Chrome версии 53.0.2785.92 (64-разрядная версия) - Omid
Это резко уменьшает мерцание, но оно все еще присутствует в Google Inbox, например (в настоящее время это единственное место, где я его вижу). - TiGR
Работает, но теперь отображается только левый верхний угол некоторых изображений. Что для меня было хром: // flags / # ignore-gpu-blacklist - Jasny - Arnold Daniels


Откройте терминал и введите следующую команду:

sudo nano /usr/share/applications/chromium-browser.desktop

и прокрутите вниз, пока не дойдете до этой строки:

Exec= chromium-browser

Затем добавьте эти два параметра

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Нажмите Ctrl + O, чтобы сохранить и Ctrl + X, чтобы выйти.

Затем введите следующую команду:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

и добавьте эти строки

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Нажмите Ctrl + O, затем Ctrl + X.

Откройте Chromium и напишите в адресной строке: chrome://flags/ и введите.

  • Enable-ноль-копия
  • Включить переопределение списка отображения программного обеспечения
  • Включить отображение 2D-листа

Наконец, откройте настройки хрома и нажмите:

  • Использовать аппаратное ускорение при наличии

38
2017-07-27 08:10



Работала на моем Dell XPS 15 95050 Intel® Core i7-6700HQ с процессором 2,60 ГГц Intel® HD Graphics 530 (Skylake GT2). - Prydie
В моем случае (после нескольких решений) я просто включил те флаги, которые вы упомянули (zero-copy, Override Software Rendering List, Display 2D List Canvas), и, похоже, он исправил ее (на графике Intel HD). - Nahuel
Два переключателя командной строки (отключить обходные методы / включить собственные буферы памяти gpu) больше не работают, но создают 20-intel.conf файл работал для меня! Также включена растеризация gpu (не уверен, что это важно). - terabaud
Единственное работающее решение для меня. благодаря - Darkside
Просто добавление 20-intel.conf работал на меня - не нужно было ничего делать. - Vadi


Я исправил его следующим образом:

sudo apt-get purge xserver-xorg-video-intel

затем перезагрузитесь. Это связано с тем, что драйверы Intel переместились в режим настройки. Для получения дополнительной информации см. этот комментарий в потоке ошибок Chromium,


37
2017-08-19 14:25



Я пошел по маршруту хром-флажков, а затем отправился на этот маршрут и сбросил флаги по умолчанию и очистил материал intel. Все идет нормально. - Sethen
Благодарю. У меня есть NUC Intel, которому несколько лет, и прошло несколько обновлений. Это на 16.04.2, но ваше предложение действительно нашло пакеты для очистки. Он больше не мигает (мой HDMI-видео мигает и включается и выключается примерно на 1 или 2 Гц после некоторых последних обновлений, я думал, что он развил аппаратный сбой после 8 лет службы). - Tim Richardson
Этот ответ должен быть намного выше! - Galgalesh
Это оно? Он работает безупречно !!! Полностью недооцененный ответ. Большое спасибо! - uloco
Благодаря! Это поставило проблему для меня. Ваш ответ должен быть на несколько пунктов выше, чем есть. - Anthony D.


Ни один из этих ответов мне не помог. Что я в итоге сделал, что кажется , чтобы зафиксировать его (моя ссылка была на этом сайте http://www.bang-olufsen.com/ который мерцал, как CRAZY, и теперь он работает плавно) заключается в следующем:

1.- Перешел на chrome://gpu/, Вот что он показал:

enter image description here

2. Я попытался решить проблемы один за другим. В моем случае, если эти флаги фиксировали некоторые из них: GPU rasterization, Override software rendering list, Затем он показал следующее:

enter image description here

3.- Я отредактировал панель запуска и добавил параметры --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers,

4.- После этого больше не обнаруживается никаких проблем, все проявляется как «аппаратное ускорение» и, что более важно, больше не мерцает:

enter image description here

Если вы сначала добавите параметры в панель запуска, список проблем должен быть короче, и, вероятно, будет легче определить, какие флаги помогут вам в решении проблем, которые у вас остались.


24
2017-09-14 12:29



Это хорошая рекомендация. Я использовал его для решения моей проблемы с firefox, где он был просто решен путем удаления «Использовать аппаратное ускорение» в дополнительных настройках. - Bach
Это уменьшило мерцание для меня, но это все еще часто случается ... - addison


С Chrome версии 51.0.2704.103 (64-разрядная версия) флаги

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

больше не работают.

Лучшим способом, который мы можем сделать, является переход на Chrome 50 (версия 50.0.2661.86 (64-разрядная версия)), вот инструкция, как вы можете отступить: как мне понизить хром Google? 

Важно, что мы оказываем давление на Google, чтобы исправить эту проблему, проголосовать за ошибку в Chromium и на странице продукта google:

https://bugs.chromium.org/p/chromium/issues/detail?id=606152

https://productforums.google.com/forum/#!topic/chrome/CtKF2BiskT8;context-place=forum/chrome


7
2018-06-19 08:02



Не работает для меня. - ComBin
@ComBin: вы пробовали вернуться к v50 и использовали флаги? Однако, следуйте ссылке на хромовую ошибку, есть масса различных предложений по решению, чтобы заставить эту работу работать с текущими версиями хром / -ium. - user157697
Я не хочу v50, спасибо. Я нашел лучший способ исправить это, см. Мой ответ ниже. - ComBin
AHa, в хромовой ошибке, ребята означали, что это будет иметь серьезные проблемы с производительностью. Однако я попробую некоторые предложения от хромовых ошибок, когда у меня будет время, насколько я понял, Хром - это только симптом, а не причина. Я буду держать вас в курсе, если найду что-то лучшее / другое. Приветствия. - user157697


chrome://flags/ > GPU rasterization > Enable,

Это, наконец, помогло мне! Нашли его внизу этой формы Google! https://productforums.google.com/forum/#!msg/chrome/CtKF2BiskT8/dLXKfU2XAQAJ


5
2017-10-16 20:44