Вопрос: низкое ядро ​​в 17.10 ставит машину в непригодное состояние


Ядро lowlatency, появившееся в моем обновлении 17.04-> 17.10, поставило мою машину в непригодное состояние. (Этот новый сорт ядра не упоминается в примечаниях к выпуску 17.10.) Ввод grub, начиная с основного ядра, а затем полностью удаляя

Linux-изображений 4.13.0-16-lowlatency

(используя синаптический) исправил мою проблему.

Мой вопрос в основном: что происходит? Как заставить мою машину работать с ядром с низкой степенью уязвимости?


6
2017-10-24 01:58


Источник


Ядро с низкой латентностью может быть нестабильным, поскольку оно приносит в жертву стабильность для скорости. Это сомнительно, если это даже необходимо - wiki.linuxaudio.org/wiki/system_configuration#the_kernel «Ядра> = 2.6.31, похоже, работают очень хорошо без RT patch, а также для использования в режиме реального времени для профессионального использования. Не нужно больше устанавливать ядро ​​реального времени ('rt') для получения хороших результатов. результаты по-прежнему ожидаются при использовании ядра реального времени. Попробуйте, протестируйте его и решите сами ». - Panther
Используйте ядро ​​с низкой задержкой и отправьте отчет об ошибке из любого места, где у вас есть ядро. - Panther
Если вы установите новый Ubuntu 17.10, вы получите generic ядро. Сначала я обновился с 17.04 по 17.10, а также закончил с lowlatency, после переключения ядра на общий, не удалось запустить GNOME. Решил отказаться и установить свежие 17.10. Проблемы исчезли. - NeverEndingQueue
У меня такой же опыт. Я много лет использую серии ядер с низкой степенью достоверности по многим выпускам без проблем. Но с Арци я получаю вялые движения мыши и клавиатуру, пропускающую ключевые хиты. - wilx
Если вы отправите отчет об ошибке, вставьте здесь ссылку. Я буду участвовать. - wilx


Ответы:


Я почти что угадываю здесь, но возможно, что ваша система может загружаться только при загрузке определенных модулей ядра, которые не поставляются с ядром. Затем они должны быть построены с использованием dkms, но это работает только если у вас есть соответствующая linux-headers-4.13.0-16-lowlatency установленный пакет. Когда вы устанавливаете этот пакет, соответствующие модули ядра будут автоматически созданы для вас.

В общем случае пакет заголовков всегда должен устанавливаться, когда изображение установлено, но по какой-то причине это происходит не всегда автоматически.


2
2017-11-02 13:14



Я просто попал в ту же самую проблему; 17.04 - 17.10 автоматическое обновление установило ядро ​​с низкой степенью неопределенности, но не заголовки. Оставив мою систему сломанной, потому что она запускала закрытые драйверы NVidia, которые молча (без ошибок) не смогли правильно установить из-за недостающих заголовков, - они отметили недостаток, но, похоже, не рассматривали его как проблему. (Господи, помоги мне, я скучаю emerge @module-rebuild...) - FeepingCreature
Возможно, связано с ошибка 1728760? - Jesse Glick