Вопрос: Почему мой git не работает с bzr-make?


Я хочу сделать deb пакет для virglrender в Ubuntu 16.04.

Для git я сделал

git clone git://people.freedesktop.org/~airlied/virglrenderer
cd virglrenderer/
ls
./autogen.sh 
make
make install

Теперь я хочу упаковать

bzr dh-make  virglrenderer 102016git virglrenderer-102016git.tar.gz 

но это дает мне эту ошибку

bzr: ERROR: Either run the command from an existing branch of upstream, or move virglrenderer/ aside and a new branch will be created there.

я сделал

cd ..

и повторить

bzr dh-make  virglrenderer 102016git virglrenderer-102016git.tar.gz 

но снова дайте мне эту ошибку

bzr: ERROR: Either run the command from an existing branch of upstream, or move virglrenderer/ aside and a new branch will be created there.

Как сделать? Я также попытался создать tar.gz вручную с помощью tar, ничего.


0
2017-10-09 15:13


Источник


bzr означает «Базар». Почему вы пытаетесь использовать инструмент, предназначенный для базара с git? - Erkin Alp Güney
Я, хотя был для упаковки из источника, извините, я нашел здесь команду packaging.ubuntu.com/html/packaging-new-software.html - elbarna


Ответы: