Вопрос: Замените DEB.SURY.ORG PHP оригинальным


Я добавил репозиторий Ondřej Surý, который в то время был отличной помощью. Теперь у меня проблемы с установкой cURL, и я думаю, что возвращение к «оригинальному» PHP решит проблему.

В настоящее время все мои пакеты PHP из репозитория DEB.SURY.ORG.

ii  php5                              5.5.12+dfsg-2+deb.sur all
ii  php5-cli                          5.5.12+dfsg-2+deb.sur amd64
ii  php5-common                       5.5.12+dfsg-2+deb.sur amd64
ii  php5-gd                           5.5.12+dfsg-2+deb.sur amd64
ii  php5-imagick                      3.1.2-1+debphp.org~pr amd64
ii  php5-json                         1.3.4-3+deb.sury.org~ amd64
rc  php5-mcrypt                       5.5.8+dfsg-3+sury.org amd64
ii  php5-mysql                        5.5.12+dfsg-2+deb.sur amd64

Я уже удалил файл .list для Ondřej.

Как я могу вернуться к исходным пакетам php, что вызывает минимальные сбои для моих пользователей?


0
2017-09-29 08:40


Источник


Добавить обратно PPA, использование ppa-purge, - muru
@Oli Довольно уверен, что кто-то уже сказал это, поэтому я ищу оригинал, чтобы отметить как обман. Если нет, я отправлю ответ. - muru
@muru, это решило мою проблему, и я очень благодарен. Пожалуйста, разместите его как ответ, чтобы я мог принять его. - Miklos


Ответы:


Пакеты с понижением рейтинга - очень сложная проблема. Вы должны использовать ppa-purge для этого. Но ppa-purge требует, чтобы PPA все еще добавлялся, поэтому вам нужно будет добавить PPA, а затем использовать его.


1
2017-09-29 09:20