Вопрос: Как отключить Bluetooth при запуске системы?


Как отключить Bluetooth при запуске системы?


270
2017-10-16 21:02


Источник


Я не думаю, что «должна быть естественной конфигурацией по умолчанию», люди обязаны использовать Bluetooth на своих компьютерах без необходимости включать его (у вас, кажется, нет мыши или клавиатуры Bluetooth, если это были ваши первичные устройства ввода, с которых вы хотите, чтобы Bluetooth был загружен). Однако я согласен с тем, что было бы полезно иметь способ выбрать, как вы хотите, чтобы Bluetooth был загружен. - roadmr
Нормальная и естественная вещь - позволить вам выбрать в настройках bluetooth, хотите ли вы его включать или выключать, когда он загружается. Естественно, что люди отключили его или каждый раз, когда они включали свой компьютер. Мы говорим о том, чтобы сделать Linux лучшей настольной системой, а не худшей, не так ли? - Robert
Мы согласны с тем, что выбор людей - лучший вариант. См. Здесь некоторые возможные способы сделать это. answers.launchpad.net/ubuntu/+source/bluez/+question/51440 - roadmr
Это ошибка # 1073669, - colan
Невероятно, что в 14-м издании мы все еще «учим» разработчикам Ubuntu, например, «возможность включения или выключения Bluetooth при загрузке должна быть доступна для обычных пользователей, а не только для тех, кто любит поиск в бесконечных линиях общественных форумов ». - Rodrigo


Ответы:


Пользователи 18.04+, у которых, естественно, нет /etc/rc.local, вам нужно создать их и сделать их исполняемыми. Чтобы сделать несколько проще, вы можете просто вставить следующую команду в терминал:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Бег sudoedit /etc/rc.local и добавьте это до строки с exit 0:

rfkill block bluetooth

Вы все равно должны включить Bluetooth через апплет верхнего бара.

Эта должен работают для большинства систем, но похоже, что в ядре ACPI для ThinkPad есть несколько ошибок. Если вы используете Thinkpad, добавьте следующее: /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Или проверить ibm-acpi - драйвер IBM ThinkPad ACPI Extras - некоторые сообщения говорят о том, что ibm-acpi включает в себя управление Bluetooth (среди других приятных вещей). Но у меня нет оборудования, поэтому я полностью не могу проверить эти претензии. Удачи.


187
2017-08-18 09:00



Для Thinkpads (и только ThinkPad) это работает: echo disable > /proc/acpi/ibm/bluetooth в /etc/rc.local - Marius Gedminas
rfkill block bluetooth работал на Thinkpad T430u - bmaupin
Ни один из них не работал для меня (ThinkPad x201), когда я поместил их по одному в /etc/rc.local, rfkill block bluetooth команда работает, но не при запуске. Флаг -x установлен на /etc/rc.local, Я запускаю Xubuntu 13.10. - Kyle Falconer
На Ubuntu 15.10 с Systemd вам нужно еще немного, чтобы повторно использовать использование etc/rc.local файл: askubuntu.com/a/696226/34298 - rubo77
если наш rc.local является просто пустым файлом, где мы должны добавить «bluetooth bluetooth»? - Sss


Я нашел практическое руководство с чистым «обходным решением», Вот (ссылка на архив для потомков)

Фактически изменение /etc/bluetooth/main.conf было достаточно для меня.

Из статьи:

Поиск записи:

InitiallyPowered = true

и измените значение на:

InitiallyPowered = false

Этого было достаточно для меня, хотя в статье описаны некоторые другие шаги, которые могут быть или не быть необходимыми.

На Ubuntu 17.10 а также Ubuntu 18.04 опция InitiallyPowered был заменен на AutoEnable


67
2018-06-25 18:00



не работает для ноутбука samsung 530u3b, bluetooth всегда включен после перезагрузки и пробуждения - Maxim Kim
Это будет работать, только если я воспользуюсь ответом Саида Заринфама /etc/init.d/bluetooth stop в rc.local. Похоже, что когда услуга запускается, она также подключается к bluetooth. Мне нужно было, чтобы это работало. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
Не работал для меня на thinkpad t420 - UpTheCreek
«Поиск записи» совершенно бесполезен для тех из нас, чей main.conf не содержит этот параметр или комментарий, указывающий его местоположение по умолчанию. Итак, под [Heading] мы должны сказать? - underscore_d
В моем случае это был AutoEnable = false, но anyways +1 для правильного решения из нужного места. - Arman Petrosyan


Чтобы отключить драйвер bluetooth от загрузки при запуске:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

Добавить:

blacklist btusb

Включение этого позже должно быть просто:

sudo modprobe btusb

23
2017-08-18 16:59



Спасибо за это, похоже, это работает, но я старался избегать командной строки в соответствии с моим оригинальным вопросом. Вы могли бы подумать, что это будет так же просто, как поставить отметку в ящике, чтобы он помнил, что я не хочу, чтобы BT запускался автоматически, но выглядит более сложным. С приводом Ubuntu для более быстрого времени загрузки и общей сосредоточенностью на энергопотреблении в ноутбуках и нетбуках я удивлен, что это никогда не рассматривалось. Однако я ценю помощь.
«Запустить gedit как root и отредактировать /etc/modprobe.d/blacklist.conf» <- ok, это меньше командной строки для ya? - maco
Прекрасно работает на Samsung Q35 с Ubuntu 13.10, в то время как подход «bluetooth bluetooth» не работает. Благодаря! - user27164
DELL E6410 работает для меня. Хорошо, что можно снова запустить на ходу без перезагрузки. - Ruslan Gerasimov
Не пытайтесь «избегать командной строки» при настройке операционной системы. Есть ли Ctrl + Alt + T и несколько ctrl-shift-V (чтобы вставить) слишком много, чтобы спросить? - doug65536


Шаг 1. Перейдите к терминалу и введите следующую команду, чтобы отредактировать систему. /etc/rc.local файл:

gksudo gedit /etc/rc.local

Шаг 2. Добавьте следующую строку до exit 0 линия:

rfkill block bluetooth

16
2018-05-04 20:44



Это установленный мягкий блок для bluetooth, я думаю, что это так же, как отключить его обслуживание и работает хорошо. - Smile.Hunter
@Роберт: $ man rfkill: "Отключите устройство, соответствующее данному индексу.«Несмотря на название, он отключает BT, просто попробуйте команду rfkill block bluetooth на терминале, вы должны увидеть значок серого цвета. - Daniel


Начиная с ubuntu 16.04, systemd управляет сервисами запуска, такими как bluetooth ... для просмотра текущей проблемы состояния, следующей в терминале

sudo systemctl status bluetooth.service 

деактивировать bluetooth при запуске

sudo systemctl disable bluetooth.service

то при следующей перезагрузке bluetooth не будет активен ... для включения проблемы Bluetooth

sudo systemctl enable bluetooth.service

12
2017-08-01 15:08



Это работает для меня, но, как побочный эффект, blueman-апплет также перестает работать. Он запускается, но не отображается в области индикатора, поэтому нет быстрого способа включения bluetooth, только в терминале. - Yuri Gor
В Xubuntu, по крайней мере, если вы нажмете на Blueman, у него есть опция «Отключить Bluetooth». Я думаю, что это то, что OP хотел бы автоматизировать. Ваше решение полностью удаляет Blueman, что затрудняет повторное включение Bluetooth, если это необходимо. - Adrian Keister
Положите sudo systemctl disable bluetooth.service && sudo systemctl остановите bluetooth.service в отключенном скрипте и chmod 755 на нем. Сделайте то же самое для sudo systemctl, включите bluetooth.service && sudo systemctl запустите bluetooth.service в сценарии Enable. - Adrian Keister


Введите в терминал следующее:

sudo gedit /etc/modprobe.d/blacklist.conf

В нижней части файла добавьте строку:

blacklist bluetooth

Сохраните файл и перезапустите - теперь Bluetooth должен быть отключен.


7
2017-10-16 21:25



Это не будет работать на моем компьютере ... - Floqqi
@Floqqi: Повторите попытку? Я обновил свой ответ. - Nathan Osman
Пробовал около 20 вещей на моем ubuntu 12 thinkpad, это единственный, кто сделал трюк. - OlivierBlanvillain


Вы можете изменить службы, запущенные при загрузке, с помощью БОМЖ,

Установите его: sudo apt-get install bum

Бег: sudo bum

enter image description here 

Снимите флажок и нажмите Подать заявление,


7
2018-05-05 00:09



Спасибо, дегуа, я думал об этих инструментах. Я использовал некоторые в прошлом, но они устарели, и новый ubuntu, с их минималистичной одержимостью, не имеет ничего подобного. Является ли это единственным йо или лучше знать? - Robert
Может быть, работает, но сначала он разочаровал меня, потому что он начал показывать bluetooth как не активированный во время загрузки, почему? и, как не работает, когда rfkill, апплет и hciconfig показывают, что он работает. Я выключаюсь и выключается, но bum продолжает показывать сервис как отключенный. Я активировал службу при загрузке, но статус службы продолжает быть неправильным. - Robert
извините, не работает на elementaryOS Freya - Hoang Tran
При запуске я получаю много предупреждений о «использовании неинициализированных значений». Извините, не могу этого доверить. - doug65536
Теперь пакет недоступен. Говорят, Бум виртуальный. - Satya Prakash


Я думаю, что лучший способ - отключить сервис от запуска в первую очередь. Существует общий метод отключения служб, который отлично работает:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Это работает для Ubuntu 13.10 и, вероятно, для более ранних версий.


5
2018-01-18 09:49



как включить Bluetooth, используя при этом дополнительные настройки? Я хочу использовать его всего 5 минут. каждые 10 ботинок .. - b1r3k


я добавить

"/etc/init.d/bluetooth stop"

в

"/etc/rc.local" 

перед командой «exit 0» для загрузки с выключенным bluetooth.


5
2017-08-23 13:00



это сработало для меня, спасибо! - woohoo
Это удалило значок лотка bluetooth, но отключило индикатор моего bluetooth (показывая, что питание все еще посылается на радио). Изменить: это в сочетании с ответом Степбера (InitiallyPowered = false) работал для меня. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
это не сработало на моем 64-битном Ubuntu 14.04 dell inspiron. Только рфкилл работал для меня. - faizal


1. Блокировать bluetooth в rc.local

Добавьте эту строку в конец файла /etc/rc.local прямо перед линией exit 0:

rfkill block bluetooth

Это будет делать трюк, но только в более старых версиях Ubuntu, используя выскочка,

2. reenable rc.local на systemd

На Ubuntu 15.10 с Systemd как диспетчер запуска /etc/rc.local файл больше не используется по умолчанию, поэтому вызовите это на терминале:

sudo systemctl edit --full rc-local

Открывает редактор. В конце файла я добавил:

[Install]
WantedBy=multi-user.target

Эти изменения активируются

sudo systemctl reenable rc-local

Теперь файл /etc/rc.local используется, как вы это знаете.

3. отключить blueman-апплет при запуске

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Теперь blueman-апплет виден, и вы можете отключить его от программ запуска

4. Перезагрузите, чтобы увидеть эффект


5
2017-11-10 12:29



Для меня на Ubuntu 17.04 с blueman: gsettings set org.blueman.plugins.powermanager auto-power-on false работал от wiki.archlinux.org/index.php/Blueman, Хотя я закончил sudo apt remove blueman затем выполните управление Bluetooth через системные настройки и установите флажок «Показывать статус Bluetooth в строке меню». Проблема с Blueman - запуск и включение Bluetooth. - Michael Jackson


Вы можете редактировать свои update-rc.d Настройки. Я использовал что-то похожее:

sudo update-rc.d bluetooth remove

В Debian Wheezy. Проверять, выписываться man update-rc.d для получения дополнительной информации о том, как его использовать.


4
2018-02-13 15:50